Mastodon

ATH10k: QCA9888: schlechte Performance und Abstürze (C6 v2, EAP225-Outdoor, ...)

Ich habe einen Archer C6 v2 seit einigen Wochen im Einsatz. Der Preis, die Funkreichweite, und die vielen Ethernetports find’ ich klasse. Leider ist der Betrieb relativ unzuverlässig und ich muss ihn häufig über den Netzstecker neu starten. Kann das mit dem ‚neuen‘ 5 GHz-Chipsatz und mangelhaftem Treiber zu tun haben?

Kann ich 5 GHz in dem Knoten deaktivieren?

Wenigstens im Bezug auf den nightly Branch ist mir ein Problem leider bewusst. Grund ist wohl das der bislang verwendete Treiber für das Radio verbuggt ist.


Eine Möglichkeit ist, wie du schon richtig vermutest 5 GHz zu deaktivieren.

Das geht einerseits grafisch im Config Mode oder per ssh folgenderweise:

Als erstes musst du schauen ob radio0 oder radio1 für das 5 GHz WLAN zuständig ist:

root@ffrn-example:~# uci get wireless.radio0.band
2g
root@ffrn-example:~# uci get wireless.radio1.band
5g

In dem Fall wäre das also radio1.

Anschließend führst du die folgenden Kommandos aus:

uci set wireless.radio1.disabled=1
uci set wireless.client_radio1.disabled=1
uci set wireless.mesh_radio1.disabled=1
uci set wireless.owe_radio1.disabled=1
uci commit wireless
wifi

Nun sollte das 5GHz Radio abgeschaltet sein. Das kannst du dann noch mit iw dev kontrollieren.


Mögliche Problemlösung:

Es wurde nun im Gluon master Branch der ath10k Treiber für die Wave2 Radios gewechselt:

In unserer nightly Firmware ist das auch schon drin. Bislang sieht es ganz gut aus.

Du könntest also deinen Knoten auch auf nightly umstellen. Das könnte helfen.

Unsere nightly ist aber eben keine stable. Einerseits gibt es häufigere Updates, andererseits ist es wahrscheinlicher das in diesen Bugs drin sind.
Unschön ist beispielsweise: Status Page: multiple data collection processes · Issue #2468

Der Branch lässt sich so wechseln:

uci set autoupdater.settings.enabled=1
uci set autoupdater.settings.branch=nightly
uci commit autoupdater
autoupdater -f

Ein Wechsel zurück zu stable ist nur ohne behalten der Einstellungen möglich.

Super, auf 5 GHz kann ich gerne verzichten, ich werde das mal probieren und berichten falls es immer noch Probleme gibt. Da ich erst morgen Abend daheim bin werd’ ich das erst später testen, da ich solche Modifikationen lieber mache wenn ich direkten Zugriff auf die Kiste habe. Wenn sonst das Netz ned läuft gibt’s Megga von der beste aller Ehefrauen.