Bug aktuelle Firmware gluon-ffrn-1.2.x-20190107-tp-link-tl-wr841n-nd-v12-sysupgrade.bin?


#1

Hab mich extra mal hier angemeldet (obwohl ich schon lange FFRN nutze), um meine aktuelle Erfahrung mitzuteilen.

Auf einem meiner FFRN-Router (tl-wr841n-nd-v12) lasse ich oft auch gern die neueste nightly laufen. Aktuell war es die Version vom 20190107, vielleicht auch schon vorherige, die womöglich den selben Fehler produzieren.

Fehlerfall bei mir:
Kein Traffic ins Internet mehr möglich über diesen Router wenn ich per wlan verbunden war. Auch Neustarts etc halfen nicht. Pings per putty verbunden auf dem FFRN-Router, egal ob von lokal oder
direkt verbunden, funktionierten aber!!!

Nach einer downgrade/recovery-Odyssee läuft nun wieder 1.1.6-20180621 - womit wieder normales surfen möglich ist.

Falls es nur ein Fehler bei mir ist, bitte ich das zu entschuldigen. Aber vielleicht hilft es auch anderen…
Wobei meinen Router laut interner Statistik es nur noch zwei User betreiben:
image

mfg
dckhsn


#2

Moin,

danke für dein Feedback

Wie ist das genau gemeint und was ist der unterschied zwischen lokal und direkt verbunden? Was war dein Ziel für den Ping?


#3

Hi
& gerne doch bzw. muss man ja der Community danken für den Einsatz ;-)

Lokal ist mit gemeint vom heimischen Netzwerk aus, womit auch der FreifunkRouter versorgt wird (=das private Netzwerk). Und direkt verbunden meinte ich per “freifunk-rhein-neckar.de” Wlan-Verbindung zum Freifunk-Router.
Als Ziele hatte ich “gmx.de” und die ip-adresse “1.1.1.1” jeweils probiert. Beides zeigte das gleiche Verhalten wie oben beschrieben.
Ich hoffe, ich kann damit ein wenig weiterhelfen.

mfg
dckhsn


#4

Sind die nightly’s im moment eigentlich überhaupt lauffähig ?

und wenn ja, auf basis von welchem Gluon werden sie gebaut ?:thinking:


#5

Hi

Die letzte die ich ja bewusst genutzt hatte, wo ich die Probleme hatte waren die von 20190107.
Und die lief zwar bei mir, nur konnte man darüber halt nicht ins Internet. Davor die Versionen kann ich nichts zu sagen, da ich das nicht so genau beobachte bzw. auch nur selten nutzte.

Aktuell gibt es wohl ne neuere, gerade nachgeschaut:


Momentan, auch wenn davor eigentlich immer alles klappte, traue ich mich diese Version nicht zu testen.

mfg
dckhsn


#6

Auf einer ziemliche aktuellen Basis.

Definiere lauffähig. Das sind halt Versionen mit potenziellen Bugs. Dazu gehört z.B. auch das beschriebene Phänomen das die Verbindung nicht klappt. Da fehlte z.B. noch was im Backend. Da wird aktuell von @NurticVibe ziemlich viel umgebaut und daher auch getestet um die Multidomain Fähigkeit herzustellen. Sieh auch: Stand der Firmwareentwicklung


#7

Aktuell ist die Nightly firmware nicht zu empfehlen. Die Änderungen im Backend (sprich Gateways) sind zwingend notwendig, damit diese Firmware wieder vollständig funktioniert.
Generell sollte “nightly” sowie auch “devel” auch nur eingesetzt werden, wenn man sich der folgen im klaren ist. Folgend ein Zitat unserer Firmwareseite

Die Nightly Firmware wird bei jeder Änderung im Gluon Repository Des nächsten Releases ( aktuell Branch 2018.2.X ) automatisiert erzeugt.


#8

Genau das hatte ich ja auch schon vermutet. Daher kam ja auch meine Frage.

@NurticVibe: Gibt es neues zum Stand der Dinge? Wann ist denn z.B. eine erste (testbare) Version geplant? als Experimental ? (jaja, klar, "… when it’s done" , aber ein Update erfreut die Community :sunglasses:) …


#9

Das Multidomain Feature wurde wegen anhaltender Probleme vorerst nach hinten geschoben. Ein normales Release mit Gluon 2018.2 kommt allerdings heute Nacht in Nightly und Experimental.


#10

Hallo zusammen & danke @NurticVibe für die Infos/Neuigkeiten.

Kleine Rückmeldung von mir. War mal wieder mutig genug…
Zuerst /etc/config/autoupdater auf experimental gesetzt und per console autoupdater -f probiert. Nix tat sich, da wohl von der alten zu der neuen es nicht mehr so klappt zu upgraden?! egal.

Danach mir das neue Image manuell runtergeladen und per winscp auf den router nach /tmp.
gluon-ffrn-1.2.0-20190213-tp-link-tl-wr841n-nd-v12.bin per sysupgrade -v befehl installiert…

Und: Es läuft alles. Sogar besser wie die 1.1.6-20180621, da hier die prozessorlast nicht astronomische höhen erreicht und somit wohl auch das w-lan stabil bleibt.

Eine Frage hätt’ ich aber noch: Ich hab erst später gesehen, dass ich das File für die Erstinstallation drübergebügelt hatte und nicht die sysupgrade. Macht das keinen unterschied wenn schon freifunk-firmware drauf ist?

mfg
dckhsn


#11

Ich würde immer den weg über “uci” empfehlen. In diesem Fall wäre das:

uci set autoupdater.settings.branch='experimental'
uci commit

Im Idealfall macht es keinen Unterschied, man sollte aber immer das Upgrade file nutzen - Sicher ist sicher.