RaspberryPi konfiguration

Hallo zusammen,

ich habe mir mit einem RaspberryPi Model B und einem USB-WLAN-Stick einen Freifunk Router zur Erweiterung meines Netzwerks gebaut.
Die Anbindung läuft über die LAN-Schnittstelle über mesh on wan zu meinem Offloader (baut also keine eigene VPN-Verbindung auf). Den Stick habe ich per Nachladen der ath9k-htc treiber auch zum laufen gebracht und das Ganze funktioniert auch so weit. Mein Problem jetzt ist, dass die eingeloggten WLAN-Nutzer nicht als WLAN-Nutzer auf der Karte zu sehen sind sondern als „andere“. Auch die Airtime wird nicht angezeigt. Funktioniert das mit USB-Adaptern nicht oder habe ich da noch einen Fehler irgendwo drin?

Hi @Dread,

das Problem bei den PIs ist das die eigentlich nicht gut für Freifunk geeignet sind. Der Prozessor unterstützt unser aktuelles VPN Protokoll fastd nicht gut und perfomant, man hat nur einen einzelnen Netwerkport, das integrierte WLAN läuft oft leider nicht stabil und USB-WLAN Sticks die 802.11s (das meshen per WLAN) unterstützten sind auch rar. Und dann stehen Preis und Leistung nicht wirklich in einem guten Verhältnis zueinander. PIs sind super, aber es sind eben keine Router oder Access Points.

So viel zum allgemeinen, du scheinst aber ja schon relativ weit gekommen sein. Ich will nur andere etwas abschrecken, einfach weil ich denke das fast alle günstigen Router besser sind als so ein Pi zur Verwendung als Freifunk Node. :wink:

Ich kann dir leider auch nicht sagen was gute USB WLAN Adapter sind. Ich habe bisher leider noch keine wirklichen voll umfängliche Erfolgsgeschichten gehört. Es haben zwar schon ein paar Leute probiert, aber irgendwie waren die alle nicht wirklich glücklich.

Das was du beschreibst kling für mich so als ob da eventuell der Adapter dem System gegenüber als Ethernet Port auftritt. Wie man das aber, falls es wirklich so ist, verändern kann, kann ich dir leider auch nicht sagen. Eventuell hast du den falschen oder nicht alle notwendigen Treiber nachgeladen?
Wie hast du denn das WLAN konfiguriert? Oder ging das automatisch beim ersten boot?

Sorry das ich nicht wirklich helfen kann :sweat_smile:

Hi,

dass jeder 20€ Router besser geeignet ist als ein Raspi ist mir bewusst.
Nun ist es halt mal so, dass ich das Teil ungenutzt hier rumliegen habe und auch gerne ein wenig bastle und probiere - man will ja was lernen. Aber prinzipiell bin ich voll bei dir. Ist also ein reines Funprojekt und nicht zur Nachahmung empfohlen.

Nun zum Raspi:
Ich habe beim ersten boot über die Konsole erstmal route und dns auf meinen Heimrouter umgebogen und so direkt die Wlan Treiber nachgeladen. Danach konnte ich wie gewohnt über das Webinterface alles konfigurieren und neu booten. Danach habe ich nur noch die wireless Einstellungen angepasst:
wireless.default_radio0.network=‚lan‘ auf ‚client‘ umgestellt, da sonst zwar das netzwerk ausgestrahlt wurde aber keine Verbindung zu Stande kam und wireless.default_radio0.ssid=‚OpenWrt‘ auf ‚freifunk-rhein-neckar.de‘ (Soll ja stimmen…)

Mittlerweile habe ich festgestellt, dass mir ein Interface fehlt. Es wurde nur wlan0-1 angelegt. So wie ich das verstanden habe, sollte das ja nur für die Mesh Verbindung verantwortlich sein. Wlan0 fehlt.

Ja, als Funprojekt ist das durchaus etwas was man machen kann :slightly_smiling_face:

Ich habe hier mal uci show wireless auf einem TL-WR1043ND v2 ausgeführt, so sieht das normalerweise aus:

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/qca955x_wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.channel='13'
wireless.radio0.country='DE'
wireless.radio0.legacy_rates='0'
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname='mesh0'
wireless.mesh_radio0.network='mesh_radio0'
wireless.mesh_radio0.device='radio0'
wireless.mesh_radio0.mesh_fwding='0'
wireless.mesh_radio0.mesh_id='ffrn-mesh'
wireless.mesh_radio0.mcast_rate='12000'
wireless.mesh_radio0.mode='mesh'
wireless.mesh_radio0.disabled='0'
wireless.mesh_radio0.macaddr='8e:dd:b3:87:12:31'
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname='client0'
wireless.client_radio0.network='client'
wireless.client_radio0.disabled='0'
wireless.client_radio0.device='radio0'
wireless.client_radio0.mode='ap'
wireless.client_radio0.macaddr='8e:dd:b3:87:12:30'
wireless.client_radio0.ssid='freifunk-rhein-neckar.de'
wireless.owe_radio0=wifi-iface
wireless.owe_radio0.ifname='owe0'
wireless.owe_radio0.network='client'
wireless.owe_radio0.encryption='owe'
wireless.owe_radio0.device='radio0'
wireless.owe_radio0.ieee80211w='2'
wireless.owe_radio0.disabled='0'
wireless.owe_radio0.mode='ap'
wireless.owe_radio0.macaddr='8e:dd:b3:87:12:32'
wireless.owe_radio0.ssid='owe.freifunk-rhein-neckar.de'

und iw dev sollte in etwa so aussehen:

phy#0
        Interface owe0
                ifindex 14
                wdev 0x4
                addr 8e:dd:b3:87:12:32
                ssid owe.freifunk-rhein-neckar.de
                type AP
                channel 13 (2472 MHz), width: 20 MHz, center1: 2472 MHz
                txpower 15.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       653147  403     0       0       37793   47719314                727197
        Interface client0
                ifindex 13
                wdev 0x3
                addr 8e:dd:b3:87:12:30
                ssid freifunk-rhein-neckar.de
                type AP
                channel 13 (2472 MHz), width: 20 MHz, center1: 2472 MHz
                txpower 15.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       4596880 320     0       0       229700  314619920               4810133
        Interface mesh0
                ifindex 12
                wdev 0x2
                addr 8e:dd:b3:87:12:31
                type mesh point
                channel 13 (2472 MHz), width: 20 MHz, center1: 2472 MHz
                txpower 15.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       35194324        4309    0       0       1794    3366988764              35880565

Danke, das hat geholfen.
Beim Raspi ist das was bei dir als „client_radio0“ angelegt ist als „default_radio0“ angelegt. Allerdings ohne interface-name.
Ein „uci set wireless.default_radio0.ifname=wlan0“ und
ein „uci add_list network.client.ifname=wlan0“ hat Abhilfe geschaffen.
Das ganze muss natürlich mit „uci commit“ und anschließendem „/etc/init.d/network restart“ bestätigt und aktiviert werden.
Funktioniert jetzt alles wie es soll.

1 Like