SSH Befehle für Neueste FW 1.04


#1

Hallo Community.
Meine Frage ist für viele bestimmt kalter Kaffe, trotzdem ist’s mir nicht gelungen, Antworten im Forum oder Wiki zu finden. Ich bin auch immer unsicher, ob Befehle, die für alte Firmware gültig war , weiterhin gültig sind. Da gab es wohl größere Umstellungen ( Lede? Was ist das ? )

Konkret würde ich gerne per SSh Befehl das Clientnetz einschalten. Ich habe einen Router in der Gausstraße ( LA-RW-Gss003), auf dem immer 0 clients sind und da vermute ich , dass die Jungs auf den Wifi Knopf gerückt haben , wahrscheinlich weil sie den Reset Knopf gesucht haben.
Also, kann ich den Status von wifi client Netzt abfragen und das ganze Remote einschalten?
Danke für eure Hilfe


#2

Bei LEDE handelt es sich um einen Fork von OpenWRT, dieser wird aktiver entwickelt.
Wenn du wissen möchtest, was ein Fork ist: https://de.wikipedia.org/wiki/Abspaltung_(Softwareentwicklung)
Mit:
uci show wireless

root@ffrn-msu:~# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/qca955x_wmac'
wireless.radio0.htmode='HT20'
wireless.radio0.channel='6'
wireless.radio0.country='DE'
wireless.radio0.supported_rates='6000' '9000' '12000' '18000' '24000' '36000' '48000' '54000'
wireless.radio0.basic_rate='6000' '9000' '18000' '36000' '54000'
wireless.wan_radio0=wifi-iface
wireless.wan_radio0.macaddr='9e:96:d9:bd:2b:3b'
wireless.wan_radio0.network='wan'
wireless.wan_radio0.encryption='psk2'
wireless.wan_radio0.device='radio0'
wireless.wan_radio0.mode='ap'
wireless.wan_radio0.key='test12345'
wireless.wan_radio0.ssid='nix'
wireless.wan_radio0.disabled='1'
wireless.mesh_radio0=wifi-iface
wireless.mesh_radio0.ifname='mesh0'
wireless.mesh_radio0.network='mesh_radio0'
wireless.mesh_radio0.device='radio0'
wireless.mesh_radio0.mesh_fwding='0'
wireless.mesh_radio0.mesh_id='ffrn-mesh'
wireless.mesh_radio0.mcast_rate='12000'
wireless.mesh_radio0.mode='mesh'
wireless.mesh_radio0.disabled='1'
wireless.mesh_radio0.macaddr='9e:96:d9:bd:2b:39'
wireless.client_radio0=wifi-iface
wireless.client_radio0.ifname='client0'
wireless.client_radio0.network='client'
wireless.client_radio0.disabled='1'
wireless.client_radio0.device='radio0'
wireless.client_radio0.mode='ap'
wireless.client_radio0.macaddr='9e:96:d9:bd:2b:38'
wireless.client_radio0.ssid='freifunk-rhein-neckar.de'

siehst du, was Sache ist, genauer genommen hier:
wireless.client_radio0.disabled=‘1’

Sollte das client:radio0 disabled sein, dann ist es aus. Wieder einschalten wäre dann:

uci set wireless.client_radio0.disabled=0;uci set wireless.client_radio1.disabled=0;uci commit wireless;wifi

Grüße
Michael


#3

Ich empfehle dir einfach immer hier zu gucken. Dort stehen die Versionen und welche Befehle die Richtigen sind:


#4

Danke
Ich habe es tatsächlich geschafft, meine neuen Router in der Gausstraße per ssh vernünftig zu konfigurieren. Danke auch an @Bitboy
Das ist ein gutes Gefühl für mich , weil es ja auch enorm Zeit spart, nicht in die Unterkunft fahren zu müssen. Über weitere Probleme dort berichte ich im anderen Post