TL-WR841ND bekommt keine IP-Adresse mehr vom Router

Hallo,

habe letztes Wochenende mal damit gespielt die WAN und LAN-Ports zu tauschen. Ich dachte, dass ich nicht gespeichert hätte und demnach nichts geändert hätte. Jetzt habe ich festgestellt, dass ich auf dem WAN-Port vom DSL-Router keine IP-Adresse mehr bekomme.

Habe ich eine Chance über die LAN-Ports oder WLan per SSH auf den Router zu kommen?
Hat der Router vielleicht eine statische IP/IPv6 über die ich drauf kommen kann?

Danke für Euer Infos.
Tschüss Jo

Lässt sich der Router in den Konfigurationsmodus versetzen (8 Sekunden Reset drücken)?
192.168.1.1 und 10.142.255.1 schon probiert?
Mit statischer Konfiguration deiner Netzwerkkarte?

Was hast Du denn genau geändert bzw. versucht zu verändern?

Hallo,

soweit ich mich erinnere habe ich nur /etc/network/interfaces gewechselt. Hm, da fällt mir ein in der einern Anleitung stand was von wegen, dass man noch ein wan bzw lan nach /sys/class/net/ schreiben sollte.

Die Frage was ich kaputt gemacht habe stellt sich mir auch noch gar nicht so recht, zunächst muss ich erst mal wieder auf die Box drauf kommen.

@hdvalentin genau so einen Tipp habe ich gesucht. Sollte diese Adresse auf dem WAN-Port oder den LAN-Ports ansprechbar sein? Habe beides probiert leider ohne Erfolg. Habe inzwischen auch die Seite https://wiki.openwrt.org/toh/tp-link/tl-wr841nd#tftp_recovery_via_bootloader_for_v8_v9_v10 gefunden. Habe zwar noch kein TFTP getestet. Auf ping antwortet die Kiste mir allerdings weder auf die 192.168.1.1, 192.168.086 noch 10.142.255.1. Natürlich befindet sich meine Kiste im selben Subnetz und der Network Managager ist deaktiviert.

Achso, mein Exemplar ist V8.

Habt Ihr noch konkrete Hinweise, Kochrezepte wie ich da ran komme?
Sollte telnet oder ping antworten oder reagiert die Kiste nur auf tftp?

Macht es einen Unterschied ob ich den Reset per Reset-Button oder Power-On-Reset mache?

Habe jetzt auch mal mit Wireshark gesnifft. Ich sehe einen IPv6 Broadcast vom Router. Den kann ich allerdings nicht anpingen. Das Wifi ist aktiv, ich sehe freifunk-rhein-neckar und meine ‘private’ SSID, allerdings bekomme ich auf keinem der Interfaces (WAN, LAN, WLAN) eine IP-Adresse per DHCP.

Ich beginne mich mit dem Gedanken anzuvertrauen, dass ich mich von dem Gerät verabschieden muss.
Was meint Ihr?

Du kannst dich mal mit dem WLAN/WAN/LAN Verbinden und deinem Rechner die statische IP 10.142.255.2/24 geben und dann versuchen die 10.142.255.1 via SSH zu erreichen. Das sollte dann gehen.

Die Dinge bekommst du nicht kaputt. Im Zweifel (wenn obiges nicht geht) sollte es auch gehen, wenn du direkt nach dem Booten die WPS/Reset Taste drückst bis die System LED ganz schnell blinkt. Dann bist du im Failsafe Modus. Dort kannst du per telnet über die 192.168.1.1 (du musst dir die 192.168.1.2/24 statisch konfigurieren) auf den Knoten zugreifen und ihn mit dem dem hier aufgeführten Prozedere wieder auf den Zustand nach dem flashen bringen: https://wiki.openwrt.org/de/doc/howto/generic.failsafe Dabei gehen dann aber alle Einstellungen inkl. VPN Key hops. Den musst du daher nach dem Reset in der Registry aktualisieren.

Es ging mir bei der Frage auch nicht darum, wie man es wieder heile bekommen, sondern was vielleicht gerade kaputt ist. Viele Linuxe sind leider sehr pingelig was die Konfig-Dateien für das Netzwerk angeht, und wenn man da an einer Stelle was falsches reinschreibt dann geht Netzwerktechnisch oft garnichts mehr. Habe mich so auch schon mal ausgesperrt. Falls Du Deine Kiste mit Bens Tipps Softwaretechnisch nicht mehr zum Laufen bekommst, können wir immer noch den Lötkolben schwingen und Dir eine Textkonsole anschließen. Damit bekommt man eigentlich so ziemlich alle Geräte wieder zum laufen.

Konnst Du zufällig aus der Gegend Bensheim/Lorsch?

Hallo,

so, bin wieder auf der Kiste drauf aber sie tut noch nicht was ich möchte.

Über den Failsafe Mode habe ich die Dateien /etc/config/network und /lib/gluon/core/sysconfig/[lw]an_ifname auf den PC gesichert. Habe dann noch einen anderen Router (wr841nd v9) konfiguriert und die Dateien gesichert. Dabei ist mir aufgefallen dass meine Änderungen am Wochenende doch nicht rückgängig gemacht hatte und einige Fehler in der Datei ‘network’ hatte.

Habe jetzt die Fehler behoben und diff zeigt mir außer der MAC Adresse keine signifiikaten Unterschiede mehr an.

Nach einem Neustart ging der Router den Modus, dass ich auf der blauen Buchse über die IP-Adresse 10.142.255.1 per ssh rein kam. Nach einem weiteren Neustart (Power Off Reset) startete der Router fast normal im Freifunk-Modul. Allerdings habe ich jetzt wie ursprünglich geplant auf der blauen Buchse das FF-Netz und auf den gelben das Lokale Netz der Fritz-Box.

Kann es sein, dass zwischen HW-Release V8 und V9 die Interfaces eth0 und eth1 vertauscht sind? Von den Anschlüssen sind sie ja wirklich vertauscht. Die Einstellungen für /etc/config/network und /lib/gluon/core/sysconfig/wan_iface bzw lan_iface sind wie oben beschreiben so ziemlich identlisch.

Soweit mal Danke für Eure Unterstützung!

War mir auch neu, du hast recht:

https://wiki.openwrt.org/toh/tp-link/tl-wr841nd

Ich habe hier einen Offloader mit drei ETHs … wenn du mal hier postest, was du geändert hast, könnte ich mir davon vielleicht abschauen, wie ich auf der Kiste WAN,LAN und MESH auf die drei Buchsen bekomme …? Weil zur Zeit habe ich da nur WAN und MESH und die dritte Buchse macht nichts erkennbares.

Hallo,

sorry für die späte Antwort. Also auf der TL-WR841ND V8 habe folgende Dateien verändert:

  • /lib/gluon/core/sysconfig/wan_ifname
  • /lib/gluon/core/sysconfig/lan_ifname
  • /etc/config/network
  • /lib/gluon/core/sysconfig/setup_ifname (da bin ich mir nicht mehr sicher)

Folgendes steht jetzt in den Dateien:
/lib/gluon/core/sysconfig/wan_ifname (ohne trailing new line)
eth1
/lib/gluon/core/sysconfig/lan_ifname (ohne trailing new line)
eth0
/lib/gluon/core/sysconfig/setup_ifname (ohne trailing new line)
eth1
/etc/config/network

  • in der Sektion "config interface ‘wan’"
    ersetze
    option ifname 'eth0’
    durch
    option ifname ‘eth1’
  • in der Sektion "config interface ‘client’"
    ersetze
    option ifname 'eth1’
    durch
    option ifname ‘eth0’
  • in der Sektion "config interface ‘mesh_lan’"
    ersetze
    option ifname 'eth1’
    durch
    option ifname ‘eth0’