Flüchtlingsunterkunft Lampertheim Gausstraße mit stark schwankender Performance?

Hallo zusammen. Seit einigen Tage bekomme ich aus der Gausstraße immer wieder die Meldung, dass Internet nicht verfügbar sei, Wenn ich dann auf Grafana schaue, sieht eigentlich alles gut aus.
Wir reden hier von LA-RW-GSS 1-6a

Die Laufzeit der Router ist im allgemeinen nur ein paar Stunden. Das könnte bedeuten, dass sie öfters Neustarten, oder dass die Jungs da selbst Hand an die Router legen ( was ich befürchte).

@leah Gibt es auch Protokolle, ob und wie gut der Offloader mit dem uplink von Unitymedia versorgt wurde? Das könnte ja der Grund sein, Freifunk rockt, aber Unitymedia macht immer wieder schlapp? Insgesamt scheint seit der Umstellung auf die neue Firmware eigentlich die Datenrate gestiegen zu sein…

https://stats.ffrn.de/dashboard/db/nodes?from=now%2Fd&to=now%2Fd&orgId=1&refresh=1m&var-Node=LA-RW-GSS-001&var-Node=LA-RW-GSS-002&var-Node=LA-RW-GSS-003&var-Node=LA-RW-GSS-005&var-Node=LA-RW-GSS004a&var-Node=LA-RW-GSS006a

Hier kann man sehen, dass die Router öfter Neustarten. Das geht natürlich auf die Performance. Ich weiß leider nicht , warum sie Neustarten!

Folgendes brauchen wir um weiter zu debuggen:

  1. Alle betroffenen Knoten bitte einmal Kaltstarten (Strom raus, 1 Minute warten, Strom wieder rein) und weiter beobachten
  2. Debug Logs eines Crashes (entweder aus dem Storage oder über UART/TTL Adapter)
  3. Genaue Beschreibung der Umgebung (Mesh Setup, WLAN Umgebung, Client Anzahl etc.)

Sieht nach dem gleichen Problem aus wie bei mir (siehe Probleme mit Stable 1.1.0). Der TL-WR1043 v1 hat nur 32 MB RAM und ich habe mehrmals festgestellt, dass die RAM-Auslastung bis 95% angezeigt wird und wenn ich dann versuche die Webpage des Knotens aufzurufen oder mich per ssh anzumelden stürzt das Teil ab und bootet neu. Ebenso offenbar auch wenn zu viele Clients sich versuchen anzumelden oder nach entsprechend längerem Betrieb. Bei anderen TL-WR1043 im Netz mit v1 habe ich vergleichbar kurze Laufzeiten gesehen (einige Minuten bis Stunden). Bei den TL-WR1043 v2 oder v3 (mit 64 MB RAM) scheint das Problem nicht aufzutreten, da sie Laufzeiten über mehrere Tage anzeigen.

@NurticVibe: Du kannst Dich am besten auf einen der Knoten in Reilingen selbst einloggen, da ja Dein SSH-Schlüssel dort hinterlegt ist. Ich habe keine Ahnung, wie ich die gewünschten Logs erzeugen soll. Oder Du gibst mir eine genauere Beschreiung dazu. Kaltstarten habe ich schon mehrmals getan, ändert an dem Verhalten aber nichts.

Zum Setup: Offloader und Mesh-Setup über LAN/WAN, Meshen über WLAN ist deaktiviert, ebenso wie VPN an den Knoten. Der Offloader läuft stabil.
https://map.ffrn.de/#!v:m;n:f8d11150bce6

Dafür habe ich die nächsten Wochen keine Zeit. Versucht das bitte innerhalb der Community zu klären wie man an solche Logs kommt. Haben wir IMHO auch schon zu genüge erklärt.

Auch wenn ich denke, das es am Geräte selbst am schnellsten zu debuggen wäre - gibt es auch einen Link wo man das mit den Logs nachlesen kann?

Ich verstehe durchaus, dass ihr auch noch anderes zu tun habt, aber ohne irgendeinen Hinweis wie ich das mit den Logs machen soll komme ich hier tatsächlich nicht weiter. Kann mir auch gern jemand aus der Community sagen und ich bemühe mich mich nicht zu doof anzustellen…

@trupf hast du einen RaspberryPI um via UART/TTL zu loggen?

Einen Raspi hätte ich - was braucht es noch?

Passendes Kabel und du müsstest in den Router vor Ort eine Stiftleiste einlöten.

Weitere Infos wie das geht hier: https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#serial

eventuell kannst du ja mal tauschen und den Offloader bei dir zuhause “präparieren” und dann wieder vor Ort installieren?!

Kabel geht dann vom Offloader zum Raspberry-PI und dort kannst du das Logging dann entsprechend weiterverarbeiten (würde dafür dann vor dem Offloader ssh an den RasPI weiterleiten und diesen entsprechend konfigurieren - bitte Passwort ändern!!!)

Also mit dem Kabel zum Raspi habe ich verstanden. Kabel zum Offloader geht nicht, der steht in einem anderen Raum, wo ich nicht ohne weiteres hinkomme und wenn müßte ich ein neues Kabel ziehen. Kann ich nicht im Raspi die Logs direkt in eine Datei schreiben lassen (auf die SD-Karte)? Wie könnte man so etwas machen? Verstehe ich das richtig, dass die Logmeldungen automatisch an die serielle Schnittstelle des Routers geschickt werden? Ich müßte also quasi eine Terminalsession für die serielle Schnittstelle öffnen und in eine Datei umleiten? Was wäre der Befehl dazu? Geht das mit “cat /dev/ttyUSB0 >/sdcard/file”

Ich habe gestern mit denJungs in der Gausstraße gesprochen. Sie wollen jetzt Geld sammeln, damit wir 2 von den kleinen WR841 austauschen können gegen 1043 er. Das ist sowieso sinnvoll, weil dort immer sehr viele Clients auf einem Knoten hängen. Kennt jemand gerade eine günstige Adresse, oder hat jemand gebrauchte 1043 ?

Es wäre hilfreich, wenn du noch ein paar Infos lieferst. Nicht, dass es schlecht wäre, wenn die 841Ner ausgetauscht wer, im Gegenteil. Aber ohne ein genaues Bilder der Situation vor Ort kann es sein, dass die 1043N auch nicht die Lösung aller Probleme sind.

GSS 1 und 2 sind zwei CPE 210 als Richtfunk für den Uplink. Daten kommen von Unitymedia ( 120MBit) Am Anfang sitzt ein Offloader ( oo3) ,den Leah aufgesetzt hat.
GSS 003 ist ein 1043er, GSS 4-6 sind 841er, alle hängen per Kabel im Mesh. Mesh on Wlan ist aus.
Es gibt 60 Menschen und er Unterkunft, alle männlich, YouTube ahoi

Ich habe den Eindruck als würde nicht nur ich noch Fragen zum Logging hätte;)


Vielleicht treffen wir uns mal und helfen uns gegenseitig das aus der Theorie in die Praxis zu bringen?
Abgesehen davon kann ich nur sagen: Für Unterkünfte sind Unify-APs die beste Lösung. Mit drei solcher Dinger hinter einem Offloader kann man leicht 100 Leute zuverlässig versorgen! Da stürzt nix ab und die etwas höheren Kosten für die APs sorgen dann für dauerhaft entspannten Betrieb…

Hier in Leutershausen mit 3 APs
http://s.ffrn.de/dashboard/db/unterkunft-leutershausen?refresh=1m&orgId=1

Hallo Bitboy

Danke für denTipp. Welche Unify Router meinst du komkret, was kosten die? Jetzt habe ich halt gerade 2 1043 er bestellt, weil ich es nicht besser wusste. Aber interessant wäre die Info trotzdem

Was mich halt wundert ist, dass der CPE220 auf dem Dach (LA-RW-GSS001) nie Neustarts hat, während die Gegenseite, also das Gleiche Gerät mit der gleichen Firmware ( GSS002) eben wie die anderen 841er öfter neustartet. Technisch kann ich das nicht nachvollziehen, weshalb es bei mir die Vermutung gibt, dass die Neustarts von Aussen komme, also von den Geflüchteten…
Ich weiß es aber schlicht nicht.

Such mal nach UAP-AC-Pro, wenn du weniger ausgeben willst, die UAP-AC-Lite.

Und wegen der Abstürze/Neustarts … hast du lust auf ein Treffen wo man mal das mit dem Logging angeht? Also wie man das macht und so… Es gibt da ja Anleitungen dazu, aber gemeinsam macht es sicher mehr Spaß sich da durchzugraben.

Hallo Bitboy

JA, Die Router habe ich im Netzt schon gefunden, ist halt schon eine andere Hausnummer. Aber gut , sollte ich nochmal eine Unterkunft planen, dann nur noch mit Profi Hardware.
RS232 Logging Treffen sehr gerne. danke für das Angebot. Ich habe allerdings nur ein Macbook air und einganz altes Netbook ( Atom 270).Vielleicht kann man das alte Netbook ja dafür umrüsten, Ich mache sonst nichts mehr damit. Also RS 232 Adapter auf USB habe ich noch nicht…
Hatte auch schon die Idee, die Grafana Seite vom Traffic in der Unterkunft auf einem alten LCD TV anzeigen zu lassen, vielleicht eben auch mit besagtem Netbook. Das sollte dann vielleicht dort zu einigem etwas bewußteren Umgang mit dem Internettraffic führen.
Also, wann und wo könne wir uns treffen? Ich habe hier in LAmpertheim Platz im EMIl, wo wir auch schon Mal ein FF Treffen hatten. Freitags bin ich sehr flexibel…

Dort gibt es FF, Lötkolben, Werkzeug…

1 „Gefällt mir“

Ja, warum nicht bei dir. Also mal sehen ob noch jemand dazu kommt … und dann machen wir das. Das liegt schon ewig hier rum und das mit den Abstürzen usw. sollte ja gelöst werden. Dafür brauchen die Entwickler die logs und wir die logger ;)
RS232 auf USB hab ich hier … 4 Stück aus China mit 5 oder 3,3V einstellbar. Wenn jemand einen Haben will, hat mich je so 1,20 Euro gekostet inkl Porto ;)

Ja super. den Usb Rs 232 Adapter nehmen ich auf jeden Fall schon mal.
Sag doch Mal an, wann du Zeit hast, ich bin einigermaßen flexibel dieses WOE, nur nicht Samstags morgens, da rockt der Radrepairshop im EMIL.

@trupf wollte ja auch mitmachen , oder ?

Macht doch bitte Mal 2 Vorschläge für diese WOE , wann es sein könnte

Wir sollten alle in dassselbe Thema posten statt über 3 verteilt…

Ich schlage das hier vor: Logging über RS232

Dort ist dann auch meine Antwort.

2 „Gefällt mir“